Page 1 of 18 12311 ... LastLast
Results 1 to 15 of 256

Thread: Important: Update 2.2 and account lost recovery.

  1. #1

    Post Important: Update 2.2 and account lost recovery.

    Dear Liege
    We are so sorry that many players lost their accounts after the update. Our developers just located the problem and suggested a work around.
    Please uninstall the game completely and reinstall the game from Google Play again and then you would be able to retrieve your account again.

    Best Regards

  2. #2
    I have deleted the game and reinstalled. It was linked to facebook. My username is demonguild on server 66

  3. #3
    Ive done this multiple times and bave also contacted in-game customer support who were still unable to resolve this issue I contacted them the day it got deleted and they took 2 days to respond and by that time they were able to attack me cause my bubble dropped and stole 30 million of each resource. Will you please help me recover this account I don't know who else to contact. Account is 17079602 server 11 alliance. Ark.

  4. #4
    When are Evony going to actually get off their backsides and sort this issue out? Are you going to reimburse us all for the money spent so far in a game we can no longer use, due to YOUR fault? Are you going to actually bother to do your jobs and inform those of us with Amazon devices, when we can expect this issue to be resolved? Enough people have told you there's a problem. You should have rolled back the update or fixed it by now.

  5. #5
    I lost my account on server 24 the name is Mr Peaks the id is 12237161 and the new account ID is 18359113. Please help me get my account back.

  6. #6
    DarkAngel here cience the new upgrade i cant go on to the map to collect on tiles out side my castle. I have 2 samsung deviceses and i have deleted the game completely for 11 times reinstated it and my map button still does not work it has been 6 days now and i am frustrated. I have contacted support so menny times. Please can you tell me what am i to do for i realy love the game and i do not want to quit it all together. My id that i got from support is:
    Heart broken
    Dark angel

  7. #7
    The switch account button is broken as it is being equal to the link account button so people will loose their accounts when trying to switch when adding new account..
    please fix this as i have lost a player i tried to help out while he is on vecation.

    the info:
    Server 3
    ID 10165372
    name Lady Mordred
    please link the facebook m4nc** it should be in your log files
    hope the switch account will work again fast as possible


  8. #8
    I'm so glad that u are sorry it happened. That makes me feel so much better about your company ripping me off and refusing to take ownership of your mistakes.
    Last edited by Lamarscrodum; 02-10-2018 at 01:22 AM.

  9. #9

  10. #10
    For some reason my account got unlinked and linked to a new monarch 1 account when I opened a new account by mistake, tried to cancel that but that didnt work. When I tried to log back into my user it was now linked to the new account without me activly linking as I normally would.

    Hope you can help me restore it before it drops shield.

  11. #11
    Dear james ive read a few things here that you have solved so im coming to you after many failed attempts in game i have neen screwesd many times by evony and keep playing because i love the game but 3 issues have not been solved 2 go back almost a year not because i didnt report it but because support usually never gets nack to me maybe 3 times in 50 attempts i have spent over 31k dollars and would assume id get some attention but not so anyway about a month ago it was the first day of 2 server wars ago i logged to fight server war and march preset was jumping id set it with the rainbow i wanted to hit with and before i could finish it was setting something else many players had the same proble. Well i didnt play much made a few small hits cause i dont fight with whatever troop i use strategy later i noticed all my siege were missing i was not hit and had aprox 750k lvl 10 siege they we not to be revived and all other troops were still there i was not hit 2 possibilities 1 they disapeard which i think is what happend or when i was sending smaller hits they went out cause of preset glich i dont think that hapoend cause siege are noticable when marching and i didnt notice also during svs we have the ability to revive and they were not there either anyway either way its a game glich and i want them.back ive written many times and no anser 1 time they sent me a message saying its been 3 days we have t herd from you the matter is closed but they never contacted me so i dont know what happend ive written back several times no answer again the first of the 3 problems is the same thing only long ago but still unresolved i set a preset march of 1 troop to steel a sub city with no general in case he reinforced i semt the march maybe 4 or 5 times quickly and then got the message out of troops looked at reports and game sent full marches i got no responce it was aorox 1.2mil lvl 10 mix its obviously a glich who would send marches with nongen its a sure loss i spend a lot and only ask for what is right i soent to buikd these troops and would like them replaced so i can make t12 but evony acts like im asking for blood i dont ask for anything not comming to me onky what is lost from game problems and have had many other issues but these 2 and 1 other smaller problem are the 3 that i care about the others ill forget please help me my game name is cyberdaddy server 44 my id is 14579469 thanks for any help you can give me.

  12. #12
    Hi I've lost my account in 52 I've lost my account my ID is 15399650 new ID is18672406 can you guys please help as customer support send me a message at 7 am I immediately reapply with new ID and it's now 12pm and no response. I've spend alot of money on this and expect just little bit of service since it's bean nearly 24 hours since my first message.

  13. #13
    The switch account is acting like a link not switching the account even after following your instructions to the letter. It was fine until yesterday but all it does now is ignore whether I am not even logged into Facebook or even logged into a different Facebook account and just states “you previously logged in as ...” and loops back to same account. I even tried starting a new game then changing - but it still does the same thing. At present I now have each account on a different device - but one is a very old iPad and the battery doesn’t last. I can’t switch to my phone as that is “ looped” to another account and also won’t switch. Pleas3 resolve your switch option ASAP I cannot lug 3 devices around all day!

  14. #14
    Perdi acesso a minha conta
    Meu celular foi roubado e não tenho acesso ao email cadastrado
    Se possível vincular ela em uma nova conta seria ótimo

    Conta perdida ID 17246016
    Nova conta para vincular ID 21085852

  15. #15


    Meu celular foi roubado perdi acesso e não tenho mas o e-mail por favor me ajuda a recupera conta muito dinheiro investido
    Conta antiga ID 17246016
    Nova conta para vincular ID 21085852

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts